Ubidots Community

Graph changes accuracy from 3 decimal places to 2

Hi, I have a simple dashboard set up for an iSpindel showing a graphic and a graph for 3 values - Specific Gravity(SG), temperature and battery voltage. All were working OK for a while. But now the accuracy of graph for SG keeps changing from 3 decimal points to 2 decimal points. The other graphs stay unchanged. The data from the iSpindel is all OK. If I quit and restart all is OK for a minute or so then it changes again. The actual base data is unchanged.
The graphs and the graphics are all standard.
Any ideas why?

Hello @andydb,

I’m trying to recreate your problem (not with an iSpindle, though), but for that I still need to know a couple of things. Could you please tell me what your account decimal places number is (this can be found at My Profile > Preferences). Also, I would like to know if the widget for the SG has the decimal places value at Auto or if you put it at 3.

To be quite honest, I find it strange that this is happening since I have several widgets that have different decimal places settings and none of them suddenly change. I would like to make sure it is not a bug.

-Sebastian

Hi
My account decimal places is set at 3 and the widget is set at Auto ( I have tried setting it to 3 but the problem still existed).
I have two other widgets for temperature and battery, they are running under the same settings but they do not have the problem.

Interesting to note that this happens on both a PC and when viewing using safari on an iphone. It happens about 2 minutes after a refresh. ( I don’t want to refresh too often as I only have a stem account).

Hello @andydb,

Thank you for the additional note. After testing, we weren’t able to reproduce the issue or replicate this behavior through Safari. Could you please upload a video where you show the steps done to obtain this problem? Also, what version of Safari are you using?

-Sebastian

The time till it changes varies and can be as short as 15 seconds and as long as 20 minutes. It does not matter if real-time is enabled or not. it only happens with the specific gravity data ( not temperature or battery)
Tried to do a video but would not accept iphone video

Here is a link to the most exciting video ever!!! at about 1min 35 seconds the graph changes all on its own - as can also be seen the other 2 graphs dont change. Apple IOs/Safari version is 14.2

I’m experiencing exactly the same problem with my iSpindel data. All data is received with 5 decimal places. Everything displays fine except for the graph of gravity on the dashboard that always reverts to 2 decimal places after a short time.

Hi @andydb and @bharris,

I hope all is well.

We were able to replicate this behavior from our side. While the team solves the issue, can you please modify your account’s Decimal places for a value equal to or higher than 5? After this change, you should see the line chart as expected. We will let you know as soon as the issue is solved. Please receive our apologies for the inconvenience this could cause.

All the best,
-Isabel

HI, I’ve gone into my dash board and for the graph which is problematic ( for specific gravity) I changed the decimal places to 6, but it still changed after a couple of minutes back to 2 decimal places. In your post you referred to “account decimal Places” so I’ve changed this ( note my other widgets temperature and battery charge level do not suffer the same problem).

Note I changed the global setting to 5 decimal places but this did not resolve the problem.

Hi, @andydb,

Thank you for your prompt response.

You are right, the line chart is not showing the all decimal places the variable has, we already reported this issue with the team and let you know as soon as it is solved.

Have a nice day,
-Isabel