Ubidots Community

Actions May Not Have an Undefined "type" property

Hi,

I am trying to build a Type to apply to a group of sensors. It works fine when the variables are all raw. When I try and add a synthetic expression (one I successfully use elsewhere) it throws an error. Any suggestions?

Synthetic Expression:

Type Screen:

Error Presented:

As soon as I remove the synthetic expression the Type goes back to working.

Hi @Backpacker87,

It seems there’s a bug with synthetic variables definition in the Device type. I’ve narrowed down the problem to the color selection:

For some reason, it isn’t taking the selected color in the Name and Appearance tab of the Device type so it sends the color property empty. To quickly circumvent this bug while Ubidots team fixes it, simply select a color in the Color picker above manually and save the Type, it will then work:

–David

Hi again @Backpacker87,

Looking again at this problem, it seems it wasn’t a bug but somehow –for reason I need to investigate further, your type was misconfigured and was missing the “syntheticVariableColor” key. That was the underlying cause for the issue.
I’ve since fixed it through the API and it works now without the need of setting the color manually as I previous had mentioned.

–David

1 Like

Works perfect now. Thanks for taking care of this, you all are awesome!

1 Like