Ubidots Community

Arduino mkr 1010 wifi connection problem

Hello everyone. I have a problem with the arduino mkr wifi 1010. I followed this guide (https://help.ubidots.com/en/articles/3044424-connect-the-arduino-mkr-wifi-1010-with-ubidots-over- http) and after uploading the code to the board, the arduino becomes completely unreachable. The serial port disappears and there is no way to interact with the PC. The only way to reset the situation is to double click on the reset button to “physically” reset the board. Besides, I tried to check the wifi firmware and it seems all right and updated. What am I doing wrong? Thank you
Edit: I forgot to mention that clearly I have also tried all the various example sketches and the various types of connections to the Cloud but nothing works. Instead, the various example sketches of the wifinina library all work!

Good day dear @compalompa,

Thank you for sharing your case with the community.

Can you please make sure of the following things before trying to use one of the article examples:

1. Is my device connected to the Internet?

Even if your device seems to have a WiFi or Cellular connection, it might not be reaching the Internet.

If you are using WiFi connection, make sure your device has Internet by accessing it from an alternative device. One quick way to verify if the Wi-Fi connection is working properly, try accessing your WiFi hotspot from your mobile.

2. Can you make HTTP POST and GET requests?

  • Try making a dummy GET request to http://httpbin.org/get. If not familiar with HTTP, please refer to your device provider’s documentation to learn how to best setup an HTTP request from your chosen device.
  • Try making an HTTP POST request to a dummy URL like http://httpbin.org/post. Make sure you use the header “Content-Type:application/json

If all of the previous are working as expected, can you please send us an image of the serial monitor when trying to send data using your device or any error that you are getting when compiling the examples codes?

I’ll be attentive to your results.

–Isabel

ok i tried everything but still nothing. The arduino works normally with any other library linked to wifi and can both send data and request them. Only with the Ubidots library after the program passes the function “Ubidots ubidots (UBIDOTS_TOKEN, UBI_HTTP);” it crashes completely and does not run the rest of the program. I cannot send you the photo of the serial as it is not there! After I load the program the arduino is no longer read as a serial port and the only way I have to reprogram it is to press the power key twice to put it in bootloader mode.

Also I know that this Arduino, have linked the USB chip with the processor, so when the program has a problem, the problem can fall on the usb communication and thats why i cant open the serial.

Hi @compalompa,

Can you please let me know the version you are using of the WiFiNINA library? so we can investigate if it is something related to that.

All the best,
–Isabel

sorry for the delay:
the wifinina firmware is the 1.4.8
and in the library manager the downloaded version is the 1.8.13
wifinina check

Hi @compalompa,

Thank you for the response.

We’ll test this from our end to see what may be causing this issue. As soon as we have a better understanding of this we’ll update you of how it can be fixed.

In the meantime while we figure this out, since the Arduino can send and request data with other libraries, I recommend you use these other libraries to send data to Ubidots through HTTP requests. Please view our API Docs on HTTP for examples on the request data.

We greatly appreciate your patience.

Best regards,
Sebastián