Ubidots Community

ARDUINO MKR1010 ubidots problem

I have a problem with the arduino mkr wifi 1010. I followed this guide (https://help.ubidots.com/en/articles/3044424-connect-the-arduino-mkr-wifi-1010-with-ubidots-over- http) and after uploading the code to the board, the arduino becomes completely unreachable. The serial port disappears and there is no way to interact with the PC. The only way to reset the situation is to double click on the reset button to “physically” reset the board. Besides, I tried to check the wifi firmware and it seems all right and updated. What am I doing wrong? Thank you
Edit: I forgot to mention that clearly I have also tried all the various example sketches and the various types of connections to the Cloud but nothing works. Instead, the various example sketches of the wifinina library all work!

Please help

Aleš

Hello @alespantar,

We’re sorry to hear that you’re having trouble while working with the MKR1010 library.

Could you please try out first deleting the current library that you are using and then using the one attached here instead?
ubidots-ArduinoMKR-master.zip (42.0 KB)

We believe that this new library should fix the issue. Also, we’ll update the public library soon.

We’ll be attentive to your response.

Best regards,
Sebastián