Ubidots Community

Dashboard ignores preferences and shows what it likes

Every time I start Ubidots using Firefox on a Win11 PC, it shows me the last day or two.
Nice?
No really. The dashboard is set to show the last 30 days. Much more useful to what I’m watching. Patterns seen in the last day are horribly distorted compared the frequent fluctuations of the last 24 hours.

Is there a reason for this annoying behaviour?

Using MS Edge browser, it decides I want the current month rather than the last 30 days.

A little better as some of the datasets aren’t that old, but still, old fool that I am, I kinda expect that a setting would be used if a specific value was chosen instead of some random value plucked unwilling from the air and flung upon the screen like a reluctant turkey at christmas

@tanj666 Greetings,

As mentioned in our brief email exchange, I’ve just logged into your account in order to check the issue that you mentioned about dashboards not displaying the data according to the time interval that you set (last 30 days) and instead, it displays data for the days transcurred in the current month.

I’ve tried to reproduce the error using both Mozilla Firefox and Microsoft Edge on Windows as well as using Mozilla Firefox on a Linux machine, however, the error didn’t manifest:

As you can see from the pictures below, the dashboard is correctly displaying the data pertaining to the last 30 days:


I get the feeling that the behavior that you describe is not random at all but happens in a very specific circumstance. Having said so, I’d like to kindly ask you for graphic material that shows the error happening, it can be either GIF or .mp4 video format. Pictures would be OK too but those two formats mentioned earlier would give us more insight about the issue.

I’ll be attentive to your response.

Best regards.

Hi, I tried a few things over the last few day -
I deleted all cookies from Ubidots in case one of them held a value that was being used. I suspect I didn’t get them all though.
I deleted the dashboard page and recreated it from scratch (in firefox).

Neither attempt has got rig of the problem. It insists I want to see the last 24 hours on startup and I have to tell it go back further.

As for pictures of the problem…

Does this work? I tried to capture the screen and the current time on my PC.

Regards
Anthony

Wierdly, if I do a refresh of the screen (F5) then the date range comes out right.