Ubidots Community

Dashboard is losing its style formatting after I duplicate and rename it

I’m duplicating my dashboards, selecting the reference devices. Until yesterday, this always worked, keeping the style/colors formatting. Since yesterday, I’ve been having an issue. First, I duplicate a dashboard, choose the new reference device, and everything is fine up to that point. The problem is that, strangely, after I rename the dashboard, it suddenly changes the style completely, losing the color and font formatting. Interestingly, some widgets maintain the correct colors, while most lose the formatting.

Any idea of what might be happening? I’m using the professional plan, and I’m facing this issue right before a delivery to a client.

Thank you in advance.

Greetings @2neuron I hope you are doing great,

I’ve tried reproducing the error, however I actually couldn’t. Upon duplicating a dashboard, its widgets and styling got copied successfully.

These are the steps I performed:

  1. Created a dynamic dashboards and placed some widgets on it.
  2. Set custom style at the dashboard level for the dashboard itself and widgets (this is done through the dashboard’s custom style editor)
  3. Duplicated the dashboard

I observed that the styling of the widgets on the duplicated dashboard mirrored that of the original dashboard precisely.

Please let me know if there are any additional steps or specific conditions under which the error occurs, and I’d be happy to investigate further.

Can you also provide the name of the dashboard in which you are facing the issue? That would be helpful too.

Best regards.