Ubidots Community

iSpindel Line Chart not loading "Oops, an error occured in the widget"

Hi community.

My iSpindel dashboard used to work fine until recently. The widgets with Line Charts stopped loading, displaying the message “Oops, an error occurred in the widget”. I’ve tried to re-load the page, change timeframe, edit widget and create new widgets but the problem persists. This locks the dashboard, and I can’t select it anymore. I’ve then deleted the dashboard and created everything from scratch. The widgets worked for a short while and then stopped working again. Can someone please advise?

1 Like

Hi, andrem
I just found this thread immediately after posting an almost identical topic.

You are not alone.
I too, have the exact same issue with my iSpindel dashboard.
I too, have tried to re-load the page, change timeframe, edit widget and create new widgets but the problem persists. After trying to create a new widget, I get a blank page, but I have not (yet) been locked out. Reloading my dashboard has returned me to the same problematic page.

I posted my topic under “Data management: dashboard-widgets”.

I will let you know if I find any helpful info or solution.

Hopefully, between the two posts, we will get an answer.

1 Like

Hi Steve,

the locking out happens if you have another “working” dashboard and change the view to it. Then you can’t go back to the problematic one, and you can’t duplicate it. Only solution is to delete it.

Thank you for taking the time to comment here, for a moment I thought this was something specific to my device and I simply couldn’t find a workaround.

Please do share if they reach a solution through your topic.


Will do Andre.
Thanks for the info. It all matters.

Here’s the relevant post:

1 Like

Hi @Stevotosh7,

Have you recently updated iSpindel firmware, or added a second unit to the dashboard?


Hello Andre,

No. I have only 1 iSpindel, I have not recently updated the firmware and the only change I made was to increase the interval from 15 to 30 minutes almost 2 weeks before the problem occurred.

I received a response on the other topic which was posted a few hours ago. It reads:

"Hello, @Stevotosh7

Thanks for reaching out,

We are looking into the situation reported. Once We have a more solid answer with regards to this problem I will get back to you.



1 Like

Hey @andrem

My dashboard is working again.
I brewed a batch today and placed the iSpindel in the fermenter.
I then played around with ubidots, trying things that I tried before in editing like changing the span.
A broken border appeared around the dashboard (see below). I have not seen this before.
I then tried ( again) to create a new chart widget and, again, I got a blank page.
So I went into ‘Data’ to reload the dashboard and it loaded with all widgets working perfectly.

The broken border is still there, but everything is working well.

Is your dashboard working?

I have not yet notified Santiago on the other post as I don’t want him to stop looking for the fault and solution in case you (and possibly others) still have this issue.

In case your wondering about the the high temp, I’m using kviek yeast.

Hi Steve,

Thank you for the update. The dashboard where I was facing the issue I could not select anymore, so I had to delete it. I’ve created 2 new dashboards today, and they seem to be working so far, but they are quite generic at the moment (but the line charts are there). One of my iSpindels is off with no battery, so I will check things again when I start retrieving data from both at the same time.
Hopefully we won’t face the problem anymore…

By the way, I really like what you did with your dashboards there! Nice looking and very informative!

And yes, I did wonder about the temperature :fire:!