Ubidots Community

MQTT - Sensor Data from nodeMCU after a while changes to 0

Hi when I first tried sending data from my NodeMCU to Ubidots everything worked fine but then same code stopped giving results during the night. Next morning it worked again but now the problem is after some time all the values are turning to 0

I tried to check my serial monitor and I could see things working fine there but at Ubidots I see just 0

Hi @shaniot,

I hope all is well.

Are you on a STEM account? if yes, please keep in mind that Ubidots has a rate limit of 4,000 dots per day, if that limit is exceeded the data will not be Publish in Ubidots devices, so that probably the reason behind the sudden stop of the code.

Now, regarding values turning to 0, can you please refer to the following article and try the example code?

Additionally, are you sending data from a sensor? if yes, did you already checked the sensor measurements to discard any possible connection problems?

I will be attentive to your response to keep troubleshooting.

Best,
-Isabel