Ubidots Community

No Data Found - trying to use the ubi_speed_tester.py script

Hello - I’m completely new to Ubidots so I’m hoping someone in the community can help me figure out what’s going wrong.

I’ve diligently followed the steps in the tutorial “Test your internet speed using a Raspberry Pi + Ubidots” found here: https://help.ubidots.com/en/articles/1034842-test-your-internet-speed-using-a-raspberry-pi-ubidots

The first problem is that upon running the script as directed (yes, I did put in my API credentials), no device is created - at all. So I dug around and came across this video which instructs you to manually create the device, add the three variables for upload, download and ping and create a dashboard and add a gauge widget for each - which I’ve done.

But, the gauges simple show No Data Found. I’ve tried this three times (three completely fresh Raspbian installs) - always with the same results.

I can ping Ubidots.com from the Raspberry Pi, so it’s not a connectivity issue.

Does anyone know what I might be doing incorrectly?

Thanks,

  • Forrest

Hello @forrest_holleman,

Should you own a STEM account, could you please trying changing the server in the code from things.ubidots.com to industrial.api.ubidots.com?
2020-05-15_09-40

Also, can you make sure that you’re using your token instead of the API Key?

Looking forward to knowing the results.

Ahh - that’s where I went wrong! Once I put the token (not API key) it worked like a charm (with things.ubidots.com).

Thank you so much, Sergio!!!

Much appreciated - will continue to learn and explore with your service. I may very well be a paying customer within a week or two - love what your team has put together!

One other question, though not the main point of my original thread. The speed reading from this speedtest script is wildly inaccurate. The Raspberry Pi is connected via ethernet and is showing speeds in the range of 50-75 mbps. My desktop computer (also connected to the same switch via ethernet) shows around 330mbps. Any idea why the Pi thinks it’s much slower than it it?

All the best,

Forrest

(p.s. how do I mark this post as [SOLVED]? or is that something you do?)