Ubidots Community

None of my buttons (callbacks) are working today

I have 3 devices, each with its own dashboard, and each has buttons that activate things on the devices. I am using MQTT. Today NONE of them will work. The devices (Arduino NANO 33 IOT) never receive a callback. They do get callbacks when they reconnect for each of the buttons. The Dashboard DOES get updated when the devices request it, so the interface is working in that direction.

If I click on a button in the dashboard and then reload the web page, it sometimes sends the callback, but not very often.

Help!

Hi there, I have just tried to reproduce your issue but I have not been able, I tried with both lv and + wildcard topics and at my side I am receiving properly values:

Can you expand what topic are you trying to subscribe to?

All the best

Well of course, a couple of hours later it is working again. This has happened at least twice now - it gets really slow or the callbacks just don’t happen. I know it’s not my network connection because I run a network monitor that constantly tests the speed to different locations. I would guess Ubidots servers’ are getting overloaded.

Three of my devices have variables that cause action when a button on the dashboard is clicked (like “open the door”). Normally these work promptly. When I started this thread there was no callback at all when I clicked any of these buttons, on 3 different devices, all of which are in different locations on different wifi networks.

Will

Thanks for the report, I do not report incidences with mqtt but I will forward this report to our devops team for further analysis.

All the best

just now (01/22/2020 17:00) publish to ubidots is nearly instant, but callbacks (from switch changes on the dashboard) are taking a minute or more…