Ubidots Community

Particle Subscribing Issues with Ubidots Events

Hello everyone! I am having issues subscribing to Ubidots events. I am trying to do this example: 5. Create Ubidots Webhook to Particle to Control Things .

Ubidots is registering the events when I toggle the digital switch however Particle is not receiving. Do you all have any suggestions?

I’ve replaced the Particle_Token text with a Two-Legged Auth (Server) token in both the “Active Trigger” & “Back To Normal” body fields.

Here is the Ubidot Event Config:

When I toggle the switch, it produces points on Ubidots event view:

Here is the code:

Here is the webhook config on Particle:

Hi @Michael-Maust,

There are a couples of things that will need to be fixed or updated:

  1. You’re subscribing to an event called “UbidotsWebhook”, however, according to the webhook action setup in Ubidots, you’re calling an event called “ubidotswebhook”. Can you make sure these 2 match?
  2. We haven’t tested this integration using a Two-Legged Auth (Server) token, instead, we always created non-expiring token using Particle’s CLI as seen in the article below:
    Events: Particle functions action | Ubidots Help Center
    Please follow the step therein, create a new token with those instructions and then try again.

Last but not least, can you confirm if this still not working as expected? I saw the logs of your event and it seems Particle API responded that the webhook activations worked correctly. For example, this the last entry in the logs of your “control” event:

As can be seen here, the status code is 200 and the body also indicates a successful activation.

I’ll be attentive to your response.