Pip install ubidots


#1

Hello.
I am having problems trying to install ubidots through pip.
I searched online and tried other solutions and they still don’t work so I need some urgent help!
When I first tried it, it gave me this error:
image

Then I did a “sudo apt-get update && sudo apt-get upgrade -y”
Now when I try “pip install ubidots”, it gives me this:

Please help me solve this :sob:


#2

Greetings, your pip command seems to be searching on a wrong endpoint for the Ubidots package, the download endpoint should be https://pypi.org/project/ubidots/ instead of https://pypi.org/simple/ubidots/

My advise to you is to use a virtualenv with python3 instead of python2.7, and also to follow the instructions to install pip and ubidots:

$ sudo easy_install pip
$ sudo apt-get install python-setuptools
$ pip install ubidots==1.6.6

hope it helps you


#3

Hello

I already have python3 installed.


But I can’t install the virtualenv


#4

Greetings, thanks for contacting again. If you are getting errors installing the virtualenv package the issue is related with your distribution rather than with Ubidots, my advise to you is to ask for support in the official forums of your Linux distro.

All the best