Ubidots Community

[SOLVED] Pip install ubidots

I am having problems trying to install ubidots through pip.
I searched online and tried other solutions and they still don’t work so I need some urgent help!
When I first tried it, it gave me this error:

Then I did a “sudo apt-get update && sudo apt-get upgrade -y”
Now when I try “pip install ubidots”, it gives me this:

Please help me solve this :sob:

Greetings, your pip command seems to be searching on a wrong endpoint for the Ubidots package, the download endpoint should be https://pypi.org/project/ubidots/ instead of https://pypi.org/simple/ubidots/

My advise to you is to use a virtualenv with python3 instead of python2.7, and also to follow the instructions to install pip and ubidots:

$ sudo easy_install pip
$ sudo apt-get install python-setuptools
$ pip install ubidots==1.6.6

hope it helps you


I already have python3 installed.

But I can’t install the virtualenv

Greetings, thanks for contacting again. If you are getting errors installing the virtualenv package the issue is related with your distribution rather than with Ubidots, my advise to you is to ask for support in the official forums of your Linux distro.

All the best


I was wondering if anyone knew what is the cause of this? I did a “easy_install -U pip”.

Searching for pip
Reading https://pypi.python.org/simple/pip/
Download error on https://pypi.python.org/simple/pip/: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581) – Some packages may not be found!
Couldn’t find index page for ‘pip’ (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
Download error on https://pypi.python.org/simple/: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581) – Some packages may not be found!
Best match: pip 1.5.6
pip 1.5.6 is already the active version in easy-install.pth
Installing pip script to /usr/local/bin
Installing pip2.7 script to /usr/local/bin
Installing pip2 script to /usr/local/bin

Using /usr/lib/python2.7/dist-packages
Processing dependencies for pip
Finished processing dependencies for pip

And when I “pip install ubidots”, I get this:

pip install ubidots
Downloading/unpacking ubidots
Cleaning up…
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/pip/basecommand.py”, line 122, in main
status = self.run(options, args)
File “/usr/lib/python2.7/dist-packages/pip/commands/install.py”, line 290, in run
requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
File “/usr/lib/python2.7/dist-packages/pip/req.py”, line 1178, in prepare_files
url = finder.find_requirement(req_to_install, upgrade=self.upgrade)
File “/usr/lib/python2.7/dist-packages/pip/index.py”, line 194, in find_requirement
page = self._get_page(main_index_url, req)
File “/usr/lib/python2.7/dist-packages/pip/index.py”, line 568, in _get_page
File “/usr/lib/python2.7/dist-packages/pip/index.py”, line 694, in get_page
req, link, “connection error: %s” % exc, url,
TypeError: str returned non-string (type Error)

Storing debug log for failure in /root/.pip/pip.log

Greetings, this line:

Download error on https://pypi.python.org/simple/pip/: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify 

is telling you that your device does not have updated the required TLS certificates.

My advise is to try to update your certificates source:

sudo apt-get install ca-certificates
sudo apt-get upgrade ca-certificates

If this does not work, as I told you previously, please ask for support at your linux distribution forums as this issue is not related with Ubidots and will be better addressed by them.

Hope it helps you.