Ubidots Community

Public link shows 'No Data Found'

When accessing my dashboard widget through the public link from ‘share’ it doesn’t display and data but instead it only prints:

No Data Found
There seems to be no data to visualize in the date range you have selected

I tried to use different date ranges and styles, also regenerated the link a few times already but nothing changes.

Am I missing something here or is there a setting I overlooked to make the data really public?

Hello there,

Thank you for sharing this issue with the community,

Following up, can you please check if the variables have available data within the date range? Please note that public dashboards set the default dashboard date range. If there’s no data, you can share the dashboard with the date picker enabled, so that users can set a different time range and so being able to see data. Makes sense?

Please let me know how it goes or if you have further questions.

Hello @sergio ,

thank you for your suggestions.

The variables data is showing up fine as long as I’m logged in.

I have tried to use a dashboard with a datepicker and it didn’t show any data for a time frame where my logged-in dashboard show’s data.

Your ‘share’ dialogue looks different than mine though.

@cschlosser Can you post a screenshot of how you are sharing the dashboard URL?

@omep-developer is this what you meant:

@cschlosser It’s different because the above example from sergio happens to be for a dynamic dashboard.

That said, there must be some config set in the dashboard configuration itself that isn’t quite right. Try creating a new basic dashboard, using the share link and seeing if you still do not see the data there.

Also note that there are limits on the STEM account. I have experienced that sometimes the Ubidots interface will let me doing things that exceed my limit but then don’t display the data / devices.

@omep-developer thank you for pointing out the difference between a dashboard and a widget.
I corrected it in the initial post.

I wanted to share a single widget from my dashboard. Sharing the whole dashboard is working just fine.