Ubidots Community

[SOLVED] Correct Webhook URL for IFTT

HI i have been trying to use IFTTT to update my variable . I have referred https://help.ubidots.com/iot-projects-tutorials/home-automation-with-google-assistant-and-ubidots this tutorial but it doesn’t work.

I am getting 401 error but i have correctly given my API key.

The webhook url i used in IFTTT is - http://translate.ubidots.com/api/postvalue/?token=BBFF-MpHaie9vvq98A0GA5LzzvLjvK7iJ8e


webhoook Image can be zoomed if opened in a new tab

Greetings, why are you using your API Key? You should use a valid Token from your account. Also, from the tutorial, the endpoint for sending data is http://things.ubidots.com/api/v1.6/devices/esp8266?token={Your_Ubidots_TOKEN}, not the one that you are setting.

All the best

yes i did change it to token but yet then it returned the same error

you need to change also the endpoint, translate.ubidots.com is not a valid ingestion endpoint for HTTP.

All the best