Ubidots Community

[SOLVED] Cumsum() function not seen as valid

The Ubidots documentation says that the cumsum() function is available, but whenever I try to use it in a synthetic variable definition it says it is invalid.

I can even see photos of other people using it, for example All Time Summation of Variables - #2 by dsr

I have tried:

cumsum(VARIABLE)

and

A = VARIABLE
cumsum(A)

I have tried having the variable as another synthetic variable and as a raw variable. I have tried variations of the () since the PDF documentation has several typographical errors in the cumsum line. I have also tried giving it just a list instead of a variable, all with no success.

How can I get cumsum() to work?

Good day @coderforlife

We’re glad to see you around the community, thank you for sharing your question here.

To help you further with your problem, can you please share a screenshot of how you’re configuring your synthetic variable? I tried it and it works, please check the example below to see how you should configure it.

NOTE: Just in case, bear in mind that the variable shouldn’t be written, what you should do is select it in the menu on the right hand. Also, check that you’re using the open and close parenthesis.

All the best,
Ángela

Hello again @coderforlife

After reviewing thoroughly, I noticed that your account is in a STEM plan, which implies that the data range and advanced functions of the synthetic variables, as the cumsum() function, are not supported. We invite you to upgrade your plan if these functions are key to the project you are carrying out. Please refer to the link below to check the limits and capacity of a STEM account.

-Ángela

Thanks for clarifying! I was starting to suspect that something like that was the issue. Sadly, at the moment this is a pet project and I cannot justify a paid plan - but maybe one day if this actually works! Thanks.

1 Like