Ubidots Community

[SOLVED] Duplicate data packets

a840415621822e7c_device_values (1).zip (33.9 KB)

Hi,
I downloaded data of my LoRaWAN device from ubidots and observed lots of duplicate packets. I checked on the LoRa network server, but there are no duplicate packets available.
I wonder why I am getting lots of duplicates packets on ubidots?
I have uploaded the downloaded data file for reference.
Please note LoRaWAN device is sending data every 20 minutes intervals.
Any help with this much appreciated

Thanks
Dinesh R Gawade

Good day @dineshgawade

Please receive our apologies for the delay in replying to your note. Thank you for sharing the data file. I have reviewed the data in the variable in question and indeed there two equal values with one second of difference. Which led me to think that the values are sending in that way. Can you please send me the configuration you have in the LoRaWAN Network Server to send the data to Ubidots?

I will be attentive to your response.

All the best,
-Isabel

Hi Isabel,
Thank you so much for the help
I have attached the LoRa Network Server configuration of both sensor devices.
Presently, I am using two devices and getting the same duplicate packet issue with both.

I really appreciate any help you can provide.

Hi @dineshgawade,

Thank you for your patience while I review the information on the device configuration in TTN. Based on the images I wasn’t able to detect any mistakes in the information that could cause to have duplicate packages on Ubidots side. Additionally, I went ahead and tested the TTN’s Ubidots integration and it’s working as expected. To further investigate what could be happening, can you please delete the token that you are using? as you share it in the images and create a new one to prevent people from using it maliciously and avoid damages to your data, after that please let me know only the four last characters of the token.

All the best,
-Isabel

Hi @dineshgawade.

I want to make a follow-up and ask if you are still seeing duplicate data in Ubidots variables? Were you able to detect the reason behind this behavior?

I will be attentive to your response to keep investigating.

All the best,
-Isabel

Hi Isalogi,
Apologies for the delay in reply.
I can confirm that the duplicate packet issue has been resolved now. As you suggested, I changed the token of the device. Also, I have been monitoring packets since changing the LoRa device’s token and never seen the duplicate after that.

Thank you so much for the help; much appreciated.

Thanks
Dinesh R Gawade

Hi @dineshgawade,

Glad to here that the issue is solved now, please let me know if you need additional help.

All the best,
-Isabel