Ubidots Community

[SOLVED] Particle photon library issue

Hello

I have a particle photon, and i m trying to get it to send the data to ubidots. I m adding the ubidots librarie. But when i m compiling the code i get after adding the ubidots library i got this compilation error:
“lib/Ubidots/UbiMesh.cpp:158:8: ‘Mesh’ was not declared in this scope”
Any idea what am i missing ? i tried the example attached to the library and got the same issue.

Thanks

Greetings, please make sure that you are not using the Mesh protocol in your constructor

All the best

Thanks for the answer, i found the issue, prior to compile the code i had to select which device i wanted to actually upload the firmware to. After selecting the photon, the code compiled.

I am trying to migrate from Ubidots educational to Ubidots STEM, and incorporating the Ubidots library. I am trying to compile for an old Spark CORE, using UBI_TCP. I get the same message “lib/Ubidots/UbiMesh.cpp:158:8: ‘Mesh’ was not declared in this scope”. I have selected my device, and I can compile and upload my old code to the device (using the HTTP library, not the UBIDOTS library).

Tested - if I select one of my PHOTONs, the example code ‘SendValuesTCP’ compiles. But if I select one of my COREs, I get the message: lib/Ubidots/UbiMesh.cpp:158:8: ‘Mesh’ was not declared in this scope, even with the example code.

Greetings, the Ubidots library does not support the Spark Core since version 3.0.0. You may send data to Ubidots using the native TCP client for the Spark core as well.

All the best

Thanks. I migrated to a Photon I had around and everything’s working fine now.