[SOLVED] Rolling Window - 2 hour delay


#1

Hi all, I’m a relative Ubidots newb here. I’m attempting to produce a plot that is a rolling average of the last 10 minutes of a sensor value, so I created a rolling window variable w/ average. I set the frequency to every 10 minutes, and the start time to the time I created the variable.

Then, it took a long time to get the first datapoint on the rolling window variable. Now, I am getting a datapoint every 10 minutes, but it seems like the data is from 2 hours ago. For instance, at the time of writing, the last datapoint in the rolling window variable is from 16:50, while the last datapoint from the raw variable is from 18:38. I’m still getting new averaged points in every 10 minutes, but they’re all from the past.

Am I doing something wrong? Thanks!


#2

Hello @iPodder,

We reviewed the behavior of the rolling windows variable and we found that they are not working as should be. I’m going to assign the task for the next week to the technical team to make the revision of the issue.

I will let you know any advance on this, and thanks so much for report the inconvenience.

All the best,
Maria C.


#3

Greetings @iPodder , we have solved the delay issue with derived variables and rolling windows. Please gently make a debug test again.

Regards


#4

Hi,
I had the some problem with a Rolling Windows Variable in my Ubidots Space.
I don’t know why only a variable not permit to create a Rolling Windows.

Am I doing something wrong?
Fabio


#5

Hello.
It was solved by Ubidots Team
Thanks at all

G.