Ubidots Community

[SOLVED] Save value to ubidots

Greeting… I use save value from examples of Ubidots library of Arduino shield its not work properly. Are you make changing for your system. I use it before six months it was no problem.
Now its make restart some time make connection and send some values then return disconnecting.

Regards.

Hi @tony,

Could you please advise which library are you using? Is it for the Ethernet shield perhaps?

In addition, can you please send a screenshot of the error?

Hi @Sergio,
The library is for Ethernet shield from https://github.com/ubidots/ubidots-arduino-ethernet. Please see the screen shot below:

@tony, thanks for sharing the screenshot.

Could you please uncomment the debug line and send a screenshot of the serial console again? It’s the one red-framed in the following image.
image

Thank you @sergio for your replay,
Kindly find the the screen shot below:

Hi @sergio, pls I wait your help.
Are you ok.

Hi @tony,

My apologies for taking longer to get back to you.

It seems that there’s a connectivity issue with the API, it can due to either unstable internet connection or that you’re pointing to the wrong host. I’d recommend:

  1. Check that your device has stable Internet connection.
  2. Validate that you’re using the proper Token, it can be found at the API credentials section under your profile options
  3. Should your account is STEM, I’d recommend to declare the Ubidots instance just as the follows:

Ubidots client(TOKEN, "industrial.api.ubidots.com")

Best,
–Sergio.

Ok no problem @sergio, its important to be in healthy state. Thank you for your help.
In regards to item 1&2 both I sure they are ok, the internet is ok and my account on Ubidots is new and API credential is exact, I have currently sends some variables using ESP8266 to the same account without problem.
Item 3 not clear how to change it can you explain more?
Best,
-Tony.

@tony,

My apologies for taking this long to reply.

You have to set the server in your code, more exactly in the line where you call the Ubidots client. Please refer to the attached image that might guide you setting the proper server should your account is either Industrial accounts (including trial) or STEM.

Best,

Hi@sergio,
The problem is solved. Many thanks for you.

Regards.