Ubidots Community

TTS plugin not running


Since 1rst November my TTS plugin is stopped and I was unable to restart it.
I created a new one but it remains in “Starting” status, not Running.
From TTS side, I have errors “Fail to send webhook”, and the Event details indicate: “status_code”: 404
All Token and path seem correct
Please help me,

Hello @consulting4iot,

I deleted the plugin of your account and created it again, currently it’s running correctly. Just make sure to change the new path in TTS webhook.

Please keep in mind that when you’re creating the plugin, you’ll need to access the plugin settings, navigate to the decoder section, and ensure you click on “Save and make it live” to activate it, allowing incoming data to be received.


Hi @alejomora7
Possible that I didn’t click on “Save and make it live” after creating the new one.
I changed the path and it seems that all work properly now.
Thanks for your help

Hi again @alejomora7
I have now this error: “Request: Operation timed out”
Any idea ?


But this error is in Ubidots or TTS? I can see correctly logs on your plugin and there is no any timeout error. If you have an image it would help me.


This error is in TTN, please look at the image


I made some changes in your plugin’s decoder. The main function has to be labeled as:

async function formatPayload(args) { }

And you had modified it for function format_payload(args) { }

At the end of the code, the other change is module.exports = { formatPayload };

I ran the test payload and it worked correctly. Please verify again with TTN.


1 Like

Thank you @alejomora7
It is well working now
I dodn’t understand why it was previously working until end of october.


Perfect, great new!