Ubidots Community

Ubidots Install on Raspberry Pi 0 W

When I do the sudo pip install ubidots it does not work.

I get a ‘NewConnectionError’ and it says

Could not find a version that satisfies the requirment ubidots (from versions: )

No matching distribution for ubidots

I then tried:
$ sudo apt-get update

$ sudo apt-get upgrade

$ sudo reboot

After this didn’t work i did the following:-

$ sudo easy_install pip

$ sudo apt-get install python-setuptools

$ pip install ubidots==1.6.6

$ sudo reboot

And, even after this since it didn’t work then I did the following:-

$ sudo apt-get install ca-certificates

$ sudo apt-get upgrade ca-certificates

Still nothing worked though.
How can I get Ubidots to work with my PI?

Hello @Sparky

Can you please advise which is the python version in your RPi Zero W? Maybe this is the problem (?) since the package supports up to Python 3.4

Also, would you mind sharing a screenshot of the errors? This might provide additional insights related to the root cause of this issue.

–David

My python version on the Pi is 3.7.3

Here is the error msg I was getting:

I advise you to use the requests python package instead of the ubidots one, as the last one is not updated and maintained since some time ago. You can find several examples using requests at our docs.

All the best