Ubidots Community

[SOLVED] Issue with POST request I am getting 400 Bad Request

Following is my POST string:

POST /api/1.6/devices/ai_thinker_a9g HTTP/1.1
HOST: http://industrial.api.ubidots.com
User-Agent: AI_THINKER_A9G/1.2
X-Auth-Token: BBFF-StCcQaZdrCzmLWqaIst5LqsMtm0JOj
Content-Type: application/json
Content-Length: 94

{“sat”: 0, “spp”: 0.000000, “spq”: 0.000000, “dip”: 0.000000, “diq”: 0.000000, “in”: 0.000000}

I always get following response:

HTTP/1.1 400 Bad Request
Server: nginx
Date: Sun, 18 Oct 2020 14:19:02 GMT
Content-Type: text/html
Content-Length: 166
Connection: close

400 Bad Request

400 Bad Request


nginx

Kindly show me what i am doing wrong here…

Solved it… Thankyou all…

I was not using v1.6 but 1.6

1 Like

I am using at commends ,and mine also same error occurs,pinging is good,whenever we sent AT+CIPSEND=280 ,it gets error like
+IPD,309:HTTP/1.1 400 Bad Request

Server: nginx/1.16.1

Date: Sat, 05 Jun 2021 10:24:02 GMT

Content-Type: text/html

Content-Length: 157

Connection: close.

Hi @narendar,

I already replied to your original post, so if you don’t mind let’s keep troubleshootig in that thread.

Best,
–Sergio.

Hi,
plese send me AT commends application note for rest api over http,
I am using esp32 at commends only

regards,
naren